20 Reaktionen zu “Neue Features in 4.3 – Teil 6 OpenID”

Kommentare abonnieren (RSS) oder TrackBack URL

Danke für den Beitrag.

Ich selber stehe openID sehr skeptisch gegenüber.

Irgendwie widerstrebt es mir, einem Anbieter meine sämtlichen Accounts in die Hände zu geben. Dabei geht es nicht nur um die Vertrauenswürdigkeit, sondern auch um dessen technische Fähigkeiten (Wie werden Passwörter gespeichert, ist der Webserver sicher, ist das Netzwerk abhörsicher, etc pp)

Felix Oertel am 20. Oktober 2009 um 10:49

schon natürlich richtig. Aber du kannst natürlich auch selbst ein openID-Anbieter sein oder dein Arbeitgeber oder schlichtweg wem, dem du vertraust

Georg Ringer am 20. Oktober 2009 um 11:29

was ist denn mit vorhandenen Accounts? Können die parallel weiter laufen oder müssen die User sich neu registrieren?

Peter am 20. Oktober 2009 um 16:08

versteh nicht was du meinst. es braucht noch immer einen existierenden BE_user, man kann halt auch sich per openid einloggen

Georg Ringer am 20. Oktober 2009 um 18:08

Habe soeben versucht OpenID mit TYPO3 Backend User einzusetzen und bin gescheitert. Vielleicht ist etwas ganz Triviales was ich übersehen habe, vielleicht fehlt aber auch eine wichtige Information im Manual…
So habe ich es gemacht:
1) Extension openid installiert
2) Im BE User den OpenID identifier auf https://www.google.com/accounts/o8/meinusername gesetzt
3) Den User auf meinusername umbenannt (ist das notwendig?)
4) Ausgeloggt, auf OpenID umgeschaltet (so dass nur mehr ein Eingabefeld da war), meinbenutzername eingegeben und auf login geklickt
5) Es kam die Standard-Meldung, dass Benutzername oder Passwort falsch sei
6) Manual und Google gefragt, aber die haben auch keine Lösung gewusst 😐

Wäre toll, wenn Du mir weiter helfen könntest. Ich schätze Deine Arbeit sehr, ich stosse immer wieder auf Posts von Dir 🙂

LG
Markus

PS: Eine Liste, wie der OpenID identifier aussieht für die am weitesten verbreiteten Provider wäre toll bzw. wie man ihn herausfindet. Gibts irgendwo schon sowas?

Markus am 14. Dezember 2009 um 17:23

@ Georg:
Du musst generell diesen Link für google nutzen, egal wie dein Name lautet:
https://www.google.com/accounts/o8/id

Hauke Hain am 10. Januar 2010 um 13:03

@Hauke: Danke für Deinen Tipp, leider hat es noch immer keinen Erfolg gebracht 🙁 Selbes Verhalten wie bisher.
Was ich sonderbar finde: der OpenID Identifier, den ich beim BE-User eingebe, ist als UNIQUE definiert. Nach Deiner Info würde es dann nicht funktionieren, wenn 2 User den gleichen Provider hätten…

Markus am 11. Januar 2010 um 12:14

@Markus: Vor dem gleichen Problem stehe ich auch. Ich habe es genau so wie du gemacht. Nur liegt meine OpenID bei openid.org.
Egal ob ich nun
https://openid.org/USERNAME,
http://openid.org/USERNAME oder
openid.org/USERNAME
eingebe, ob mit oder ohne USERNAME, es kommt die Standardmeldung „Your login attempt did not succeed“.

Hat es sonst noch jemand hinbekommen?

Benjamin am 11. Januar 2010 um 15:50

Okay, so war mein Kommentar nicht gemeint. Aber so funktioniert es. 😉
Ich meinte eigentlich, dass es egal ist, welchen OpenID identifer ich im BE angebe, der Login mit USERNAME führte nicht zum Erfolg.
Der Login mit https://openid.org/USERNAME hingegen führt jedoch zum Erfolg. Bug oder Feature?
Man kann doch vom User nicht verlangen, dass er da so eine (relativ) lange URL eingeben muss? 😉
Zumal man eh einen BE-User einrichten und diesem ein Passwort geben muss.

PS: USERNAME (OpenID) ist übrigens ungleich / kann ungleich BE-User(name) sein.

Benjamin am 11. Januar 2010 um 16:10

Hat jemand OpenID mit google zum laufen bekommen?

Felix Nagel am 14. Januar 2010 um 12:31

Falls das noch von Interesse ist – so gehts mit Google:
1. ein Google-Profil erstellen unter http://google.com/profiles/me
2. die Profil-URL notieren (sieht ungefähr so aus: http://www.google.com/profiles/1234567890)
3. Die URL im TYPO3-Backend als Username und OpenID Identifier eintragen
4. Mit derselben Profil-URL (nicht https://www.google.com/accounts/o8/id!) einloggen

Tilman Becker am 27. Juli 2010 um 16:25

Hey Tilman,

vielen Dank für die Antwort — es war noch aktuell und es klappt nach deiner Anleitung super!

Felix Nagel am 27. Juli 2010 um 17:26

Da ich beim Stöbern die Kommentare hier fand… Auf meinem eigenen Server mit Version 4.4.2 klappt der openID Login nicht.
Auf Seiten die z.B. bei Mittwald liegen läuft es mit meinem myopenid-Account sofort.

Gibt es PHPseitige Anforderungen, die ich vielleicht übersehe?

Freue mich über jeden Tip 🙂

Oliver am 29. September 2010 um 17:56

Eine einfache Erklärung was OpenID für den Endanwender ist, wie es für ihn also aussieht und was er machen muss habe ich hier mal als Screencast erstellt: http://www.youtube.com/watch?v=qqFvQxD0MU4

Martin am 12. Januar 2011 um 23:12

@Tilman
Sag mal hast du seit dem google Profile Update auch Probleme dich mit OpenID einzuloggen? Zwischendrin hat google die Profile URL (also die /user.name) auf den generischen /o8/id weitergeleitet, aber es geht trotzdem nicht wieder.
Muss aber auch an TYPO3 liegen denn ich kann mit mit der generischen URL bei anderen Seiten die OpenID anbieten einloggen.

Jemand ne Idee?

Felix Nagel am 11. März 2011 um 16:17

@Felix
Bei mir funktioniert es auch nicht mehr. Ich bekomme zwar noch mal die Bestätigungsseite von Google, ob ich meinen OpenID-Account mit der TYPO3-Site verknüpfen will, aber dann scheitert die Tranaktion…

Tilman Becker am 11. März 2011 um 16:31

Mhh, Danlke für die Rückmeldung. Jetzt weiß ich wenigstens das meine Installation nicht das Problem ist.
Die Frage wäre liegt es an TYPO3 oder an Google. Vermutlich ein Zwischending, denn Goole OpenID funkioniert ja prinzipiell. Vielleicht ist die Implementierung in TYPO3 nicht ganz optimal.

Erhälst du auch PHP Fehler ala im syslog: http://pastebin.com/uC6ADaL0

Felix Nagel am 11. März 2011 um 18:40

Ich hab mal nen bug report aufgemacht zu dem Google OpenID Problem: http://bugs.typo3.org/view.php?id=17945

Felix Nagel am 15. März 2011 um 10:56

Ist schon einige Zeit her, dass sich hier etwas getan hat. Leider geht OpenID in Kombination mit Google noch immer nicht (zumindest bei mir).
Problembeschreibung:
* Extension installiert
* BE-User angelegt mit Username und OpenID-Identifier https://plus.google.com/u/0/123456789123456789323/
* Logout, auf OpenID Anmeldung geschaltet und den gleichen Identifier angegeben
* Auf die Google Seite umgeleitet und gefragt worden ob ich meine Daten teilen möchte (wow – so weit war ich bisher noch nie!)
* Nach der Bestätigung habe ich wieder das Login-Fenster bekommen (ohne Fehlermeldung)

Meine TYPO3 Version ist übrigens 4.6.7

Wenn ich Sponsoren finde, überlege ich die OpenID Extension neu zu schreiben – basierend auf dix_easylogin. Interessenten bitte per Skype bei markus.kappe melden.

Markus am 23. April 2012 um 12:43
Trackbacks & Pingbacks

[…] die unzähligen Neuerungen wurde bisher schon sehr viel und gut berichtet (1, 2, 3, 4, 5, 6, 7) , weshalb ich hier nicht näher darauf eingehen möchte. Das Changelog führt die 1656 Änderungen […]

Pingback von TYPO3 Version 4.3 – endlich da! | TYPO3 Blogger am 30. November 2009 um 11:12
Ein Kommentar hinterlassen


 Name


 Mail (wird nicht veröffentlicht)


 Website

Bitte beachten sie, dass ihr Kommentar möglicherweise erst freigeschaltet werden muss.

Kategorien

Archiv (Quick)

Dezember 2017
M D M D F S S
« Nov    
 123
45678910
11121314151617
18192021222324
25262728293031