14 Reaktionen zu “ke_search”

Kommentare abonnieren (RSS) oder TrackBack URL

Danke für diese coole Zusammenstellung…hätt ich selbst nicht besser machen können 🙂
Übrigends: Die „weitere externe Technologie“ nennt sich Sphinx.

Stefan Frömken am 28. Juni 2011 um 11:31

Hi,
ich habe die Suiche getestet – alles in Ordnung für TYPO3 – Seiten die mit den Templating Techniken vor über 5 Jahren aufgesetzt sind. Moderne, mittlere und große Seiten setzen jedoch fast ausschliesslich Templavoila ein. Der Inhalt von FCEs wird NICHT (!!!!) indiziert. Bevor ich einen Indexer für Cal etc. mitliefere ist es meiner Meinung nach für eine professionell beworbene Suchextension Pflicht, zumindest TV-Strukturen zu indexieren. Ansonsten kann ich das nicht als Mittelweg zwischen indexed_search und Solr bezeichnen sondern als hoffnungsvolles Projekt im Alpha-Stadium ! Bitte bleibt doch bei euren Artikeln realistisch !

FG am 14. Juli 2011 um 10:28

Hallo „FG“,

danke für die Anregung, die wir gerne aufnehmen.

Es ist auf jeden Fall ein cooles Feature, auch TV-basierte Seiten zu indizieren. Derzeit ist es allerdings noch nicht implementiert.

Ich möchte an dieser Stelle auch nochmal auf den Issuetracker auf http://forge.typo3.org/projects/extension-ke_search/issues hinweisen, hier können Feature-Wünsche hinterlassen werden.

Christian Bülter am 14. Juli 2011 um 11:40

Ist glaub ich gar nicht so schwer, weil TV eine API hat, mit der sich Seiten leicht „aufrufen“ lassen…
Grüße, Tim

Tim Lochmüller am 14. Juli 2011 um 19:10

Ich stell mir das auch nicht so sonderlich schwer vor. Wir haben dazu bereits ein Ticket erstellt und als kleiner TemplaVoila-Fan freue ich mich schon darauf, diese Aufgabe zu gegebener Zeit umsetzen zu dürfen.

Stefan Frömken am 14. Juli 2011 um 21:47

Da mir in einem Typo3-Forum niemand geantwortet hat und auch eine Email des Entwicklers leider bisher ausblieb, obwohl ich eine Email über das Kontaktformular geschrieben habe, versuche ich es jetzt auf diesem Wege:

Ich habe bei meiner lokalen Testinstallation vorgehabt, die neue Such-Erweiterung ke_search zu installieren.

Als ich diese aus dem TER importiert hatte und es installieren wollte und den „Aktualisierung durchführen“ Knopf drückte, kam dann die Übersicht der folgenden Fehlermeldung:

ERROR: Query could not be parsed: „SQL engine parse ERROR: Field type unknown in parseFieldDef()!: near „tags (tags), FULLTEXT content (content), PRIMARY K““. Query: „CREATE TABLE tx_kesearch_index ( uid int(11) NOT NULL auto_increment, pid int(11) NOT NULL default ‚0‘, tstamp int(11) NOT NULL default ‚0‘, crdate int(11) NOT NULL default ‚0‘, cruser_id int(11) NOT NULL default ‚0‘, starttime int(11) NOT NULL default ‚0‘, endtime int(11) NOT NULL default ‚0‘, fe_group varchar(100) NOT NULL default ‚0‘, targetpid text, content text, params tinytext, type tinytext, tags text, abstract text, title tinytext, language int(11) NOT NULL default ‚0‘, FULLTEXT tags (tags), FULLTEXT content (content), PRIMARY KEY (uid), KEY parent (pid) );“

Was soll mir dieser Fehler sagen?

Ich nutze für meine lokale Testinstallation von Typo3 die aktuelle Version von Typo3-Winstaller und die aktuelle Version von ke_search.

Vielleicht kann mir jemand dabei helfen!

Maddin am 18. Juli 2011 um 13:06

Hallo Martin,

Du hast eine Antwort unter http://forge.typo3.org/issues/28290.

Christian Bülter am 18. Juli 2011 um 13:40

Danke. Der Tipp mit der Ausschaltung von dbal und adodb hat erst einmal funktioniert. Werde aber weiter testen.

Mal ne kurze Nachfrage: Das Suchformular, dass ich im BE auswählen kann, ist auch für ke_search geeignet?

Was muss ich beachten, wenn ich das Suchformular per Typoscript ins Template einfügen möchte?

Maddin am 19. Juli 2011 um 10:03

@Maddin: deine Hinweise mit adodb und dbal haben geholfen. Habe mit der aktuellen Version die gleichen Probleme.

Björn am 28. Juli 2011 um 13:44

Hab nun auch mal die ke_search probiert und bin ziemlich begeistert. – Kann mir jemand sagen, wie man die Indexierung so einstellt, dass nur aus bestimmten Spalten (zB 0 und 1) gelesen wird? – Danke!

Robert Wildling am 05. Juni 2012 um 18:40

Ist es eigentlich geplant, irgendwelche Fuzzy Logic einzubauen?

Björn am 22. Juni 2012 um 14:54

Habe ke_search installiert (TYPO3 4.5, Realurl und tt_news) und es läuft perfekt. Innerhalb kürzester Zeit werden die Seiten und News indexiert. Leider habe ich ein Problem mit dem Suchfeld: wenn ich im Suchwort Umlaute eingebe, werden die nach Auslösen der Suche in Sonderzeichen umgewandelt und das Suchergebnis ist natürlich 0 Treffer.
Ich nehme an, dass irgendwo eine Einstellung für utf-8 fehlt – ich komme aber nicht drauf, welche. Außerdem bin ich beim Ausprobieren der Einstellungen vorsichtigt, da ich mir sonst die bestehenden Texte zerschiesse. Hat jemand das gleiche Problem und einen Lösungsansatz für mich ?

Michael am 18. Oktober 2012 um 18:48

Wir haben ke_search kurz nach erscheinen von TYPO3 4.5 komplett auf UTF-8 geändert. Kein utf8_decode oder utf8_encode mehr. Von daher vermute ich das Problem eher in Deinem TYPO3-System, dass noch nicht vollständig auf UTF-8 gesetzt worden ist.

Stefan Frömken am 22. Oktober 2012 um 21:52

Ich wollte nachfragen, ob es vielleicht Neuigkeiten an der Realurl-Front gibt – die von ke_search generierten URLs sind nicht optimal, und es gibt nirgends Doku oder eine Beispielkonfiguration. Für eine gereifte, stabile Suchextension eigentlich unentbehrlich, im Zeitalter der SEO. Danke und LG

David am 23. Januar 2014 um 12:53
Ein Kommentar hinterlassen


 Name


 Mail (wird nicht veröffentlicht)


 Website

Bitte beachten sie, dass ihr Kommentar möglicherweise erst freigeschaltet werden muss.

Kategorien

Archiv (Quick)

November 2018
M D M D F S S
« Okt    
 1234
567891011
12131415161718
19202122232425
2627282930