20 Reaktionen zu “TYPO3 4.6 ist da!”

Kommentare abonnieren (RSS) oder TrackBack URL

Ich nutze Winstaller 4.5.2 und habe zuvor schon viele Male die Typo3 Installation mit neuen Versionen versehen und bisher folgendes Problem noch nie gehabt:

Als ich mich ins BE einloggen wollte hat er mich auf einen weißen Bildschirm weitergeleitet.

Was kann ich tun, um nun die Installation so hinzubekommen, dass alles läuft?

maddin am 25. Oktober 2011 um 19:28

PHP > 5.3.x ?

Markus am 25. Oktober 2011 um 23:03

Hallo
Ich denke Markus hat recht. Schau mal in die Errorlogs von PHP. Auf dem Server ist die Ausgabe von Fehlern sicherlich abgeschaltet, aber in den Logs sollte eine entsprechende Meldung (wahrscheinlich auf Deiner PHP-Version < 5.3 eine bestimmte Funktion nicht vorhanden) erscheinen.

Grüsse,
Andre

Andre am 26. Oktober 2011 um 03:37

ich hab die meldung sofort bekommen nach dem ich den Core getauscht habe! eventuell in die localconf fehlermeldung anschalten

Markus am 26. Oktober 2011 um 12:10

Hallöle

Ich verwende die tscobj, die nun nach dem Update meine Daten nicht mehr ausgibt.

LG Sandra

Sandra am 26. Oktober 2011 um 20:35

Die Extension tscobj ist ja auch schon leicht in die Jahre gekommen. Kontrollier mal das Error Log auf PHP Fehler bzw. Warnings. Vermutlich nutzt tscobj eine TYPO3 API Funktion, die schon länger als deprecated markiert ist und jetzt aus dem Core geflogen ist.

Peter Kraume am 26. Oktober 2011 um 20:40

Danke Peter. Werd ich mal prüfen.
Hab gerad fest gestellt, dass die directmail_subscription auch nicht mehr geht.

Sandra am 26. Oktober 2011 um 22:25

multicolumn funktioniert nicht mehr: http://forge.typo3.org/issues/31057

Huaba am 27. Oktober 2011 um 00:00

Bei mir sind sp_bettercontact und rss2_import weggeknallt.

Kerstin am 27. Oktober 2011 um 09:06

Die tt_news Nachrichten wurden nach dem Update nicht mehr im Frontend angezeigt.

Weitergeholfen hat mir folgender Code im Setup der Seite:

### tt_news for 4.6
tt_content.list.20.9=CASE
tt_content.list.20.9 {
key.field = layout
0 = < plugin.tt_news
}

Johanna am 27. Oktober 2011 um 13:47

den Fall hatte ich auch, ich hab dann die neuste tt_news Version eingespielt und es ging wieder alles ;O)

Sandra am 27. Oktober 2011 um 13:50

Die neuste tt_news Version hatte ich bereits installiert. Das Problem gab’s wohl auch schon mehrfach.

Johanna am 27. Oktober 2011 um 13:56

Einen Fehler habt ihr in eurem Artikel: Die Suche im BE ist nicht komplett neu, sondern nur überarbeitet worden (nämlich so, dass sie jetzt nur noch estimmte Felder durchsucht). Neu hinzugefügt wurde sie für TYPO3 4.5.

Jörg am 27. Oktober 2011 um 20:01

@Markus & andre: Ich habe die Fehlermeldungsanzeige aktiviert und Typo3 sagt mir folgenden Fehler: Fatal error: Class ‚tx_rsaauth_backendfactory‘ not found in C:\Users\Martin\WEBSEITE\TYPO3_452\htdocs\Dummy\typo3\sysext\rsaauth\sv1\class.tx_rsaauth_sv1.php on line 123

Was hat das zu bedeuten?

maddin am 01. November 2011 um 08:24

@Sandra: Alternativen zu ext:tscobj sind unter anderem…

typoscript_code
ts_select

Josef Florian Glatz am 02. November 2011 um 09:57

Ich bekomme seit dem Update folgende Fehlermeldung im FE:
Fatal error: Call to a member function versionOL() on a non-object in /[…]/www/typo3/t3lib/class.t3lib_tstemplate.php on line 682

Konnte bisher nicht herausfinden, an welcher Extension das liegt. Hat jemand eine Idee?

Bastian am 07. November 2011 um 07:54

Wie kann ich denn Funktionen ersetzen, welche es nicht mehr in Typo3 4.6.x gibt?
Gibt es irgendwo eine Liste, wo steht, welche Funktionen entfernt wurden und durch welche Funktionen ich diese ersetzen kann?

Es gibt anscheinend sehr viele Extensions die nicht mehr auf den aktuellen Stand gebracht werden und welche dadurch das Update auf ein stabileres Typo3 verhindern.

Diese und ähnliche Meldungen gibt es seit Typo3 4.6.x des öfteren:
„Fatal error: Call to undefined method t3lib_DB::sql() in…“

Doni am 23. Januar 2012 um 07:13

Schalte im Install Tool mal das Deprecation Log an. In typo3conf werden dann Logfiles angelegt, die genauere Hinweise auf die veralteten Funktionen geben und auf den Ersatz hinweisen.

Peter Kraume am 23. Januar 2012 um 07:53

Ich habe im File localconf.php dies stehen:
$TYPO3_CONF_VARS[‚SYS‘][‚enableDeprecationLog‘] = ‚1‘;
$TYPO3_CONF_VARS[‚SYS‘][‚displayErrors‘] = ‚1‘;
Allerdings wird kein deprecation log geschrieben.
Jedenfalls nicht bei mir mit Typo3 4.6.3 unter Xampp (offline).

Doni am 23. Januar 2012 um 08:17

Seit 4.6 muss es $TYPO3_CONF_VARS[‚SYS‘][‚enableDeprecationLog‘] = ’file′; heißen.

Peter Kraume am 23. Januar 2012 um 08:45
Ein Kommentar hinterlassen


 Name


 Mail (wird nicht veröffentlicht)


 Website

Bitte beachten sie, dass ihr Kommentar möglicherweise erst freigeschaltet werden muss.

Kategorien

Archiv (Quick)

September 2018
M D M D F S S
« Aug    
 12
3456789
10111213141516
17181920212223
24252627282930